hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Rowson (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-11237) GraphiteSink metric names should not contain "="
Date Mon, 27 Oct 2014 17:15:35 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11237?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Rowson updated HADOOP-11237:
-----------------------------------
    Attachment: HADOOP-11237.patch

Patch to simply replace the '=' used in metric names with a '_'.

> GraphiteSink metric names should not contain "="
> ------------------------------------------------
>
>                 Key: HADOOP-11237
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11237
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 2.5.1
>            Reporter: Andrew Rowson
>            Priority: Minor
>         Attachments: HADOOP-11237.patch
>
>
> GraphiteSink currently outputs an equals character "=" as part of the metric key that
it outputs to graphite. Graphite doesn't currently support the "=" as part of a key, and current
Graphite trunk breaks when trying to query a metric containing this character.
> This can be worked around with wildcarding (carbon appears to store it correctly), but
it'd be good if metrics sent to graphite used only supported characters.
> I propose that we simply use a supported character such as '_'.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message