hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-11243) SSLFactory shouldn't allow SSLv3
Date Wed, 29 Oct 2014 00:44:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11243?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karthik Kambatla updated HADOOP-11243:
--------------------------------------
    Description: 
We should disable SSLv3 in SSLFactory. This affects MR shuffle among others. 
See [CVE-2014-3566 |http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3566]

We have {{context = SSLContext.getInstance("TLS");}} in SSLFactory, but when I checked, I
could still connect with SSLv3.

  was:
We should disable SSLv3 in HttpFS to protect against the POODLEbleed vulnerability.
See [CVE-2014-3566 |http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3566]

We have {{context = SSLContext.getInstance("TLS");}} in SSLFactory, but when I checked, I
could still connect with SSLv3.

       Priority: Blocker  (was: Major)
        Summary: SSLFactory shouldn't allow SSLv3  (was: Disable SSLv3 in YARN shuffle)

> SSLFactory shouldn't allow SSLv3
> --------------------------------
>
>                 Key: HADOOP-11243
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11243
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Wei Yan
>            Assignee: Wei Yan
>            Priority: Blocker
>         Attachments: YARN-2722-1.patch, YARN-2722-2.patch, YARN-2722-3.patch
>
>
> We should disable SSLv3 in SSLFactory. This affects MR shuffle among others. 
> See [CVE-2014-3566 |http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3566]
> We have {{context = SSLContext.getInstance("TLS");}} in SSLFactory, but when I checked,
I could still connect with SSLv3.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message