hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-11102) Hadoop now has transient dependency on Guava 16
Date Mon, 13 Oct 2014 20:47:35 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11102?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Loughran updated HADOOP-11102:
------------------------------------
    Attachment: HADOOP-11102-002.patch

patch that applies to trunk. The POM changes also cull the unwanted duplicate declarations
of curator as a dependency,.

> Hadoop now has transient dependency on Guava 16
> -----------------------------------------------
>
>                 Key: HADOOP-11102
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11102
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 2.6.0
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>         Attachments: HADOOP-11102-001.patch, HADOOP-11102-002.patch
>
>
> HADOOP-10868 includes apache curator 2.6.0
> This depends on Guava 16.01
> It's not being picked up, as Hadoop is forcing in 11.0.2 -but this means:
> there is now a risk that curator depends on methods and classes that are not in the Hadoop
version



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message