hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11102) Hadoop now has transient dependency on Guava 16
Date Tue, 07 Oct 2014 18:21:34 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11102?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14162244#comment-14162244
] 

Steve Loughran commented on HADOOP-11102:
-----------------------------------------

My plan: stay with guava 11 in hadoop 2.x, fix things to work there and against later versions
of Guava —so people can update if they want to, even though hadoop doesn't itself.
# fix Hadoop so it builds/runs against Guava 16 *as an option*. That means: replace classes
used in Hadoop which are not in Guava 16 with alternatives (as HBase has done)
# add a {{-Pguava-latest}} profile to verify hadoop does build against it
# roll back to Curator 2.4.1, which only depends on guava 14. AFAIK there are no classes in
guava 11 that aren't in guava 14.

Hadoop 3 can move to guava 16+



> Hadoop now has transient dependency on Guava 16
> -----------------------------------------------
>
>                 Key: HADOOP-11102
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11102
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 2.6.0
>            Reporter: Steve Loughran
>
> HADOOP-10868 includes apache curator 2.6.0
> This depends on Guava 16.01
> It's not being picked up, as Hadoop is forcing in 11.0.2 -but this means:
> there is now a risk that curator depends on methods and classes that are not in the Hadoop
version



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message