hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11102) Hadoop now has transient dependency on Guava 16
Date Wed, 17 Sep 2014 18:55:36 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11102?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14137744#comment-14137744
] 

Steve Loughran commented on HADOOP-11102:
-----------------------------------------

I need curator for YARN-913; I'd been sticking to 2.4.1 as it's jackson version was compatible
with Hadoop 2.4, and it was build against Guava 14.0.1.

Importing curator 2.6 means there's a significant risk that its eventually going to call classes
and methods that arent in the 11.02 JAR

Where does that leave Hadoop?
# do the guava update? I'm personally in favour of this. See HADOOP-10101 patch for that
# make sure that Hadoop can run against Guava 16, which means moving off anything deprecated
in the current builds, as well as working around other incompatible changes (e.g. HADOOP-10961)

What we can't do is ignore this as we now have an inconsistent set of dependencies

> Hadoop now has transient dependency on Guava 16
> -----------------------------------------------
>
>                 Key: HADOOP-11102
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11102
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 2.6.0
>            Reporter: Steve Loughran
>
> HADOOP-10868 includes apache curator 2.6.0
> This depends on Guava 16.01
> It's not being picked up, as Hadoop is forcing in 11.0.2 -but this means:
> there is now a risk that curator depends on methods and classes that are not in the Hadoop
version



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message