hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11064) UnsatisifedLinkError with hadoop 2.4 JARs on hadoop-2.6 due NativeCRC32 method changes
Date Tue, 09 Sep 2014 17:37:28 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11064?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14127277#comment-14127277
] 

Chris Nauroth commented on HADOOP-11064:
----------------------------------------

I'm +1 for short-term reinstatement of the old function signatures and ongoing work on the
long-term policy.  Colin, I agree that it's not ideal to lock ourselves into maintaining every
function signature that ever existed over time.  At least speaking for myself, I have no intention
of pointing at this as a precedent to block implementation of a proper versioning scheme.
 Hopefully that helps ease some of the very legitimate concerns that you raised.

BTW, I believe the patch you posted would break Windows.  {{NativeCodeLoader}} would attempt
to load hadoop-<version>.dll, but the Windows native build hasn't been updated to produce
a hadoop-<version>.dll instead of a hadoop.dll.

> UnsatisifedLinkError with hadoop 2.4 JARs on hadoop-2.6 due NativeCRC32 method changes
> --------------------------------------------------------------------------------------
>
>                 Key: HADOOP-11064
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11064
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: native
>    Affects Versions: 2.6.0
>         Environment: Hadoop 2.6 cluster, trying to run code containing hadoop 2.4 JARs
>            Reporter: Steve Loughran
>            Assignee: Colin Patrick McCabe
>            Priority: Blocker
>         Attachments: HADOOP-11064.001.patch
>
>
> The private native method names and signatures in {{NativeCrc32}} were changed in HDFS-6561
... as a result hadoop-common-2.4 JARs get unsatisifed link errors when they try to perform
checksums. 
> This essentially stops Hadoop 2.4 applications running on Hadoop 2.6 unless rebuilt and
repackaged with the hadoop- 2.6 JARs



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message