hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11062) CryptoCodec testcases requiring OpenSSL should be run only if -Pnative is used
Date Thu, 04 Sep 2014 17:02:52 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11062?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14121570#comment-14121570
] 

Steve Loughran commented on HADOOP-11062:
-----------------------------------------

# and {{Pnative-win}}, of course
# Or downgrade them to skip if openssl isn't on the path, if that is the problem.

FWIW SLIDER-394 covers failing fast if something is missing (winutils.exe, python, openssl);
the probe is straightforward...run the relevant version command (openssl version, python --version)
then inspect the status code & grep for expected strings back

[[https://github.com/apache/incubator-slider/blob/develop/slider-core/src/main/java/org/apache/slider/common/tools/SliderUtils.java#L1770]]




> CryptoCodec testcases requiring OpenSSL should be run only if -Pnative is used
> ------------------------------------------------------------------------------
>
>                 Key: HADOOP-11062
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11062
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: security, test
>    Affects Versions: 2.6.0
>            Reporter: Alejandro Abdelnur
>            Assignee: Andrew Wang
>
> there are a few testcases, cryptocodec related that require Hadoop native code and OpenSSL.
> These tests should be skipped if -Pnative is not used when running the tests.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message