hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9822) create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
Date Thu, 04 Sep 2014 11:17:52 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14121246#comment-14121246
] 

Hadoop QA commented on HADOOP-9822:
-----------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12634912/HADOOP-9822.3.patch
  against trunk revision 8f1a668.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-common-project/hadoop-common.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/4648//testReport/
Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4648//console

This message is automatically generated.

> create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
> -----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-9822
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9822
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.3.0
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>            Priority: Minor
>         Attachments: HADOOP-9822.1.patch, HADOOP-9822.2.patch, HADOOP-9822.3.patch
>
>
> The magic number "16" is also used in ClientId.BYTE_LENGTH, so hard-coding magic number
"16" is a bit confusing.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message