hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9244) Upgrade servlet-api dependency from version 2.5 to 3.0.
Date Sun, 14 Sep 2014 18:03:35 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9244?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14133313#comment-14133313
] 

Hadoop QA commented on HADOOP-9244:
-----------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12565588/HDFS-4422.patch
  against trunk revision 14e2639.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:red}-1 javac{color:red}.  The patch appears to cause the build to fail.

Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4718//console

This message is automatically generated.

> Upgrade servlet-api dependency from version 2.5 to 3.0.
> -------------------------------------------------------
>
>                 Key: HADOOP-9244
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9244
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 2.0.3-alpha
>            Reporter: Plamen Jeliazkov
>            Assignee: Plamen Jeliazkov
>            Priority: Minor
>         Attachments: HDFS-4422.patch
>
>
> Please update the servlet-api jar from 2.5 to javax.servlet 3.0 via Maven:
> <dependency>
>         <groupId>javax.servlet</groupId>
>         <artifactId>javax.servlet-api</artifactId>
>         <version>3.0.1</version>
>         <scope>provided</scope>
> </dependency>
> I am running a 2.0.3 dev-cluster and can confirm compatibility. I have removed the servlet-api-2.5.jar
file and replaced it with javax.servlet-3.0.jar file. I am using javax.servlet-3.0 because
it implements methods that I use for a filter, namely the HttpServletResponse.getStatus()
method.
> I believe it is a gain to have this dependency as it allows more functionality and has
so far proven to be backwards compatible.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message