hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9913) Document time unit to RpcMetrics.java
Date Mon, 18 Aug 2014 17:04:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9913?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14100859#comment-14100859
] 

Allen Wittenauer commented on HADOOP-9913:
------------------------------------------

With a bit more sleep, I have a few thoughts on this that it would be good for someone to
validate:

a) Wouldn't this be better as documentation?

b) Doesn't changing the metric like this actually 'change the metric' that is collected as
well?  i.e., this is an incompatible change?

> Document time unit to RpcMetrics.java
> -------------------------------------
>
>                 Key: HADOOP-9913
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9913
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: documentation, metrics
>    Affects Versions: 3.0.0, 2.1.0-beta
>         Environment: trunk
>            Reporter: Akira AJISAKA
>            Assignee: Akira AJISAKA
>            Priority: Minor
>              Labels: newbie
>         Attachments: HADOOP-9913.2.patch, HADOOP-9913.3.patch, HADOOP-9913.patch
>
>
> In o.a.h.ipc.metrics.RpcMetrics.java, metrics are declared as follows:
> {code}
>    @Metric("Queue time") MutableRate rpcQueueTime;
>    @Metric("Processsing time") MutableRate rpcProcessingTime;
> {code}
> Since some users may confuse which unit (sec or msec) is correct, they should be documented.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message