hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HADOOP-4201) [patch] native library build script uses unportable sed(1) regexp's
Date Fri, 18 Jul 2014 23:40:41 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-4201?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Allen Wittenauer resolved HADOOP-4201.
--------------------------------------

    Resolution: Fixed

> [patch] native library build script uses unportable sed(1) regexp's
> -------------------------------------------------------------------
>
>                 Key: HADOOP-4201
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4201
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 0.18.0
>         Environment: FreeBSD 7.0-STABLE amd64
>            Reporter: Ruslan Ermilov
>         Attachments: HADOOP-4201.patch, hadoop-0.18.0.patch
>
>
> The native library build script uses unportable sed(1) regular expressions, making it
impossible to compile a library using non-GNU sed(1).
> In particular, any POSIX-conformant sed(1) implementation will fail. The following patch
has been tested to work on both Linux (Ubuntu) and FreeBSD.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message