hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Kanter (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-10711) Cleanup some extra dependencies from hadoop-auth
Date Tue, 17 Jun 2014 00:51:01 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-10711?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Kanter updated HADOOP-10711:
-----------------------------------

    Attachment: HADOOP-10711_trunk.patch
                HADOOP-10711_branch-2.patch

The patch differs slightly between branch-2 and trunk because of other added dependencies
in trunk.  Uploading a version of the patch for each.

> Cleanup some extra dependencies from hadoop-auth
> ------------------------------------------------
>
>                 Key: HADOOP-10711
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10711
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: security
>    Affects Versions: 2.5.0
>            Reporter: Robert Kanter
>            Assignee: Robert Kanter
>         Attachments: HADOOP-10711_branch-2.patch, HADOOP-10711_trunk.patch
>
>
> HADOOP-10322 added {{apacheds-kerberos-codec}} as a dependency, which brought in some
additional dependencies.  
> {noformat}
> [INFO] \- org.apache.directory.server:apacheds-kerberos-codec:jar:2.0.0-M15:compile
> [INFO]    +- org.apache.directory.server:apacheds-i18n:jar:2.0.0-M15:compile
> [INFO]    +- org.apache.directory.api:api-asn1-api:jar:1.0.0-M20:compile
> [INFO]    +- org.apache.directory.api:api-asn1-ber:jar:1.0.0-M20:compile
> [INFO]    +- org.apache.directory.api:api-i18n:jar:1.0.0-M20:compile
> [INFO]    +- org.apache.directory.api:api-ldap-model:jar:1.0.0-M20:compile
> [INFO]    |  +- org.apache.mina:mina-core:jar:2.0.0-M5:compile
> [INFO]    |  +- antlr:antlr:jar:2.7.7:compile
> [INFO]    |  +- commons-lang:commons-lang:jar:2.6:compile
> [INFO]    |  \- commons-collections:commons-collections:jar:3.2.1:compile
> [INFO]    +- org.apache.directory.api:api-util:jar:1.0.0-M20:compile
> [INFO]    \- net.sf.ehcache:ehcache-core:jar:2.4.4:compile
> {noformat}
> It looks like we don't need most of them.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message