hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10691) Improve the readability of 'hadoop fs -help'
Date Thu, 12 Jun 2014 23:23:04 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10691?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14029995#comment-14029995

Andrew Wang commented on HADOOP-10691:

I did a quick skim through the code, looks like just help changes as expected :) Looking at
{{hadoop fs -help}}, I think chmod, chown, du, getmerge, ls, setrep could be improved with
more NLs. Things like before or after flags, paragraphs, that kind of thing.

Besides that, +1 pending. Thanks for working on this Eddy.

> Improve the readability of 'hadoop fs -help'
> --------------------------------------------
>                 Key: HADOOP-10691
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10691
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: tools
>    Affects Versions: 2.4.0
>            Reporter: Lei Xu
>            Assignee: Lei Xu
>            Priority: Minor
>         Attachments: HDFS-6521.000.patch, HDFS-6521.001.patch, HDFS-6521.002.patch, HDFS-6521.003.patch
>   Original Estimate: 48h
>  Remaining Estimate: 48h
> 'hadoop fs -help` displays help informations with numbers of different formats. 
> This patch borrows the format used in `hdfs cacheadmin -help`: all options are formatted
by using org.apache.hadoop.tools.TableListing.

This message was sent by Atlassian JIRA

View raw message