hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10652) Refactor Proxyusers to use AccessControlList
Date Wed, 25 Jun 2014 14:09:35 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10652?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14043502#comment-14043502
] 

Hudson commented on HADOOP-10652:
---------------------------------

SUCCESS: Integrated in Hadoop-Hdfs-trunk #1785 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/1785/])
HADOOP-10652. Refactor Proxyusers to use AccessControlList. (Contributed by Benoy Antony)
(arp: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1605145)
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/security/authorize/AccessControlList.java
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/security/authorize/DefaultImpersonationProvider.java
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/security/authorize/TestProxyUsers.java


> Refactor Proxyusers to use AccessControlList  
> ----------------------------------------------
>
>                 Key: HADOOP-10652
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10652
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: security
>            Reporter: Benoy Antony
>            Assignee: Benoy Antony
>             Fix For: 3.0.0, 2.5.0
>
>         Attachments: HADOOP-10652.patch, HADOOP-10652.patch, HADOOP-10652.patch, HADOOP-10652.patch
>
>
> Currently Proxyuser specification  accepts a list of users and groups including wildcard
values. Same functionality is already encapsulated in _AccessControlList_ . It will be better
to refactor _ProxyUsers_ to use _AccessControlList_ instead of maintaining separate logic.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message