hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry McCay (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10646) KeyProvider buildVersionName method should be moved to a utils class
Date Tue, 10 Jun 2014 17:07:03 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10646?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14026682#comment-14026682
] 

Larry McCay commented on HADOOP-10646:
--------------------------------------

Hi [~tucu00] - I am looking at moving unnestUri into a utils class as well.
What is your status on this jira?

We should make it the same utils class.
I'm thinking ProviderUtils.

Any thoughts?

> KeyProvider buildVersionName method should be moved to a utils class
> --------------------------------------------------------------------
>
>                 Key: HADOOP-10646
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10646
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: security
>    Affects Versions: 3.0.0
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>             Fix For: 3.0.0
>
>
> The buildVersionName() method should not be part of the KeyProvider public API because
keyversions could be opaque (not built based on the keyname and key generation counter).
> KeyProvider implementations may choose to use buildVersionName() for reasons such as
described in HADOOP-10611.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message