hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Abdelnur (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-10646) KeyProvider buildVersionName method should be moved to a utils class
Date Fri, 30 May 2014 23:20:02 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-10646?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alejandro Abdelnur updated HADOOP-10646:
----------------------------------------

    Description: 
The buildVersionName() method should not be part of the KeyProvider public API because keyversions
could be opaque (not built based on the keyname and key generation counter).

KeyProvider implementations may choose to use buildVersionName() for reasons such as described
in HADOOP-10611.

  was:
The buildVersion() method should not be part of the KeyProvider public API because keyversions
could be opaque (not built based on the keyname and key generation counter).

KeyProvider implementations may choose to use buildVersion() for reasons such as described
in HADOOP-10611.


> KeyProvider buildVersionName method should be moved to a utils class
> --------------------------------------------------------------------
>
>                 Key: HADOOP-10646
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10646
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: security
>    Affects Versions: 3.0.0
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>             Fix For: 3.0.0
>
>
> The buildVersionName() method should not be part of the KeyProvider public API because
keyversions could be opaque (not built based on the keyname and key generation counter).
> KeyProvider implementations may choose to use buildVersionName() for reasons such as
described in HADOOP-10611.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message