hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10611) KeyVersion name should not be assumed to be the 'key name @ the version number"
Date Wed, 21 May 2014 20:46:39 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14005209#comment-14005209
] 

Owen O'Malley commented on HADOOP-10611:
----------------------------------------

I disagree on this one. There is a lot of value in having semantics behind the key version.
For example, the MapReduce task ids used to be randomly generated. That was easy, but it was
a pain in the tail to figure out which tasks were related to which job. 

> KeyVersion name should not be assumed to be the 'key name @ the version number"
> -------------------------------------------------------------------------------
>
>                 Key: HADOOP-10611
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10611
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: security
>    Affects Versions: 3.0.0
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>
> The KeyProvider public API should treat keyversion name as an opaque value. Same for
the KMS client/server.
> Methods like {{KeyProvider#buildVersionName()}} and {KeyProvider#getBaseName()}} should
not be part of the {{KeyProvider}} 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message