hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10441) Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed by Ganglia
Date Thu, 27 Mar 2014 13:51:25 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10441?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13949315#comment-13949315
] 

Hudson commented on HADOOP-10441:
---------------------------------

FAILURE: Integrated in Hadoop-Mapreduce-trunk #1739 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1739/])
HADOOP-10441. Namenode metric rpc.RetryCache/NameNodeRetryCache.CacheHit can't be correctly
processed by Ganglia. Contributed by Jing Zhao. (jing9: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1582043)
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/CHANGES.txt
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/metrics/RetryCacheMetrics.java
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/ipc/TestRetryCacheMetrics.java


> Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed
by Ganglia
> ----------------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-10441
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10441
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: metrics
>    Affects Versions: 2.4.0
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>            Priority: Blocker
>             Fix For: 2.4.0
>
>         Attachments: HADOOP-10441.000.patch, HADOOP-10441.000.patch
>
>
> The issue is reported by [~dsen]:
> Recently added Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be
correctly processed by Ganglia because its name contains "/"
> Proposal: Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" should be renamed
to "rpc.RetryCache.NameNodeRetryCache.CacheHit"
> Here - org.apache.hadoop.ipc.metrics.RetryCacheMetrics#RetryCacheMetrics
> {code}
>   RetryCacheMetrics(RetryCache retryCache) {
>     name = "RetryCache/"+ retryCache.getCacheName();
>     registry = new MetricsRegistry(name);
>     if (LOG.isDebugEnabled()) {
>       LOG.debug("Initialized "+ registry);
>     }
>   }
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message