hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10441) Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed by Ganglia
Date Wed, 26 Mar 2014 20:32:22 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10441?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13948413#comment-13948413

Hadoop QA commented on HADOOP-10441:

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 1 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-common-project/hadoop-common.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/3720//testReport/
Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/3720//console

This message is automatically generated.

> Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed
by Ganglia
> ----------------------------------------------------------------------------------------------------
>                 Key: HADOOP-10441
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10441
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: metrics
>    Affects Versions: 2.4.0
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>            Priority: Blocker
>         Attachments: HADOOP-10441.000.patch, HADOOP-10441.000.patch
> The issue is reported by [~dsen]:
> Recently added Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be
correctly processed by Ganglia because its name contains "/"
> Proposal: Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" should be renamed
to "rpc.RetryCache.NameNodeRetryCache.CacheHit"
> Here - org.apache.hadoop.ipc.metrics.RetryCacheMetrics#RetryCacheMetrics
> {code}
>   RetryCacheMetrics(RetryCache retryCache) {
>     name = "RetryCache/"+ retryCache.getCacheName();
>     registry = new MetricsRegistry(name);
>     if (LOG.isDebugEnabled()) {
>       LOG.debug("Initialized "+ registry);
>     }
>   }
> {code}

This message was sent by Atlassian JIRA

View raw message