hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yoonmin Nam (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10089) How to build eclipse plugin for hadoop 2.2 or what is the alternative to program hadoop 2.2?
Date Tue, 10 Dec 2013 00:48:07 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13843772#comment-13843772
] 

Yoonmin Nam commented on HADOOP-10089:
--------------------------------------

It isn't working because the error "UNRESOLVED DEPENDENCIES".

[ivy:resolve] :: resolution report :: resolve 117ms :: artifacts dl 3ms
[ivy:resolve] WARN: 	::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] WARN: 	::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve] WARN: 	::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] WARN: 	:: org.apache.hadoop#hadoop-mapreduce-client-jobclient;2.2.0: not found
[ivy:resolve] WARN: 	:: org.apache.hadoop#hadoop-mapreduce-client-core;2.2.0: not found
[ivy:resolve] WARN: 	:: org.apache.hadoop#hadoop-mapreduce-client-common;2.2.0: not found
[ivy:resolve] WARN: 	:: org.apache.hadoop#hadoop-hdfs;2.2.0: not found
[ivy:resolve] WARN: 	:: org.apache.hadoop#hadoop-common;2.2.0: not found
[ivy:resolve] WARN: 	::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 	report for org.apache.hadoop#eclipse-plugin;working@saturn00 common produced
in /home/hadoop/.ivy2/cache/org.apache.hadoop-eclipse-plugin-common.xml
[ivy:resolve] 	resolve done (117ms resolve - 3ms download)
[ivy:resolve] 
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve] 		module not found: org.apache.hadoop#hadoop-mapreduce-client-jobclient;2.2.0
[ivy:resolve] 	==== local: tried
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-mapreduce-client-jobclient/2.2.0/ivys/ivy.xml
[ivy:resolve] 	  -- artifact org.apache.hadoop#hadoop-mapreduce-client-jobclient;2.2.0!hadoop-mapreduce-client-jobclient.jar:
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-mapreduce-client-jobclient/2.2.0/jars/hadoop-mapreduce-client-jobclient.jar
[ivy:resolve] 		module not found: org.apache.hadoop#hadoop-mapreduce-client-core;2.2.0
[ivy:resolve] 	==== local: tried
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-mapreduce-client-core/2.2.0/ivys/ivy.xml
[ivy:resolve] 	  -- artifact org.apache.hadoop#hadoop-mapreduce-client-core;2.2.0!hadoop-mapreduce-client-core.jar:
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-mapreduce-client-core/2.2.0/jars/hadoop-mapreduce-client-core.jar
[ivy:resolve] 		module not found: org.apache.hadoop#hadoop-mapreduce-client-common;2.2.0
[ivy:resolve] 	==== local: tried
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-mapreduce-client-common/2.2.0/ivys/ivy.xml
[ivy:resolve] 	  -- artifact org.apache.hadoop#hadoop-mapreduce-client-common;2.2.0!hadoop-mapreduce-client-common.jar:
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-mapreduce-client-common/2.2.0/jars/hadoop-mapreduce-client-common.jar
[ivy:resolve] 		module not found: org.apache.hadoop#hadoop-hdfs;2.2.0
[ivy:resolve] 	==== local: tried
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-hdfs/2.2.0/ivys/ivy.xml
[ivy:resolve] 	  -- artifact org.apache.hadoop#hadoop-hdfs;2.2.0!hadoop-hdfs.jar:
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-hdfs/2.2.0/jars/hadoop-hdfs.jar
[ivy:resolve] 		module not found: org.apache.hadoop#hadoop-common;2.2.0
[ivy:resolve] 	==== local: tried
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-common/2.2.0/ivys/ivy.xml
[ivy:resolve] 	  -- artifact org.apache.hadoop#hadoop-common;2.2.0!hadoop-common.jar:
[ivy:resolve] 	  /home/hadoop/.ivy2/local/org.apache.hadoop/hadoop-common/2.2.0/jars/hadoop-common.jar
[ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 		::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 		:: org.apache.hadoop#hadoop-mapreduce-client-jobclient;2.2.0: not found
[ivy:resolve] 		:: org.apache.hadoop#hadoop-mapreduce-client-core;2.2.0: not found
[ivy:resolve] 		:: org.apache.hadoop#hadoop-mapreduce-client-common;2.2.0: not found
[ivy:resolve] 		:: org.apache.hadoop#hadoop-hdfs;2.2.0: not found
[ivy:resolve] 		:: org.apache.hadoop#hadoop-common;2.2.0: not found
[ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

BUILD FAILED
/home/hadoop/hadoop2x-eclipse-plugin-master/src/contrib/build-contrib.xml:492: impossible
to resolve dependencies:
	resolve failed - see output for details
	at org.apache.ivy.ant.IvyResolve.doExecute(IvyResolve.java:251)
	at org.apache.ivy.ant.IvyTask.execute(IvyTask.java:277)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)
	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:435)
	at org.apache.tools.ant.Target.performTasks(Target.java:456)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1393)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1364)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1248)
	at org.apache.tools.ant.Main.runBuild(Main.java:851)
	at org.apache.tools.ant.Main.startAnt(Main.java:235)
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

How can I fix it?

> How to build eclipse plugin for hadoop 2.2 or what is the alternative to program hadoop
2.2?
> --------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-10089
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10089
>             Project: Hadoop Common
>          Issue Type: New Feature
>    Affects Versions: 2.2.0
>            Reporter: Asif
>             Fix For: 2.2.0
>
>
> I build the eclipse plugin for hadoop 1.2.1 but how to build it for 2.2 or is there any
alternative for it.



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message