hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rod (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9911) hadoop 2.1.0-beta tarball only contains 32bit native libraries
Date Thu, 07 Nov 2013 14:51:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13816010#comment-13816010
] 

Rod commented on HADOOP-9911:
-----------------------------

Voting for this because applications built around libhdfs depend on the binaries being available
to end users. Missing 64bit binary lib would force users to build the hdfs project which might
be simple for us, but it could be a deal breaker for end users.
As it has been pointed out, the arch specific libs had been provided in past versions. Can
we extend the "native" dir with the arch subfolders, and the appropriate libs? Thanks.

> hadoop 2.1.0-beta tarball only contains 32bit native libraries
> --------------------------------------------------------------
>
>                 Key: HADOOP-9911
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9911
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.1.0-beta, 2.2.0
>            Reporter: André Kelpe
>
> I am setting up a cluster on 64bit linux and I noticed, that the tarball only ships with
32 bit libraries:
> $ pwd
> /opt/hadoop-2.1.0-beta/lib/native
> $ ls -al
> total 2376
> drwxr-xr-x 2 67974 users   4096 Aug 15 20:59 .
> drwxr-xr-x 3 67974 users   4096 Aug 15 20:59 ..
> -rw-r--r-- 1 67974 users 598578 Aug 15 20:59 libhadoop.a
> -rw-r--r-- 1 67974 users 764772 Aug 15 20:59 libhadooppipes.a
> lrwxrwxrwx 1 67974 users     18 Aug 15 20:59 libhadoop.so -> libhadoop.so.1.0.0
> -rwxr-xr-x 1 67974 users 407568 Aug 15 20:59 libhadoop.so.1.0.0
> -rw-r--r-- 1 67974 users 304632 Aug 15 20:59 libhadooputils.a
> -rw-r--r-- 1 67974 users 184414 Aug 15 20:59 libhdfs.a
> lrwxrwxrwx 1 67974 users     16 Aug 15 20:59 libhdfs.so -> libhdfs.so.0.0.0
> -rwxr-xr-x 1 67974 users 149556 Aug 15 20:59 libhdfs.so.0.0.0
> $ file *
> libhadoop.a:        current ar archive
> libhadooppipes.a:   current ar archive
> libhadoop.so:       symbolic link to `libhadoop.so.1.0.0'
> libhadoop.so.1.0.0: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically
linked, BuildID[sha1]=0x527e88ec3e92a95389839bd3fc9d7dbdebf654d6, not stripped
> libhadooputils.a:   current ar archive
> libhdfs.a:          current ar archive
> libhdfs.so:         symbolic link to `libhdfs.so.0.0.0'
> libhdfs.so.0.0.0:   ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically
linked, BuildID[sha1]=0xddb2abae9272f584edbe22c76b43fcda9436f685, not stripped
> $ hadoop checknative
> 13/08/28 18:11:17 WARN util.NativeCodeLoader: Unable to load native-hadoop library for
your platform... using builtin-java classes where applicable
> Native library checking:
> hadoop: false 
> zlib:   false 
> snappy: false 
> lz4:    false 
> bzip2:  false 
> 13/08/28 18:11:17 INFO util.ExitUtil: Exiting with status 1



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message