hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gopal V (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10047) Add a directbuffer Decompressor API to hadoop
Date Wed, 30 Oct 2013 19:07:25 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10047?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13809495#comment-13809495
] 

Gopal V commented on HADOOP-10047:
----------------------------------

I will redo the original WIP patch's test-case for this interface - it had a decompressor
loop.

As for the method visibility, If only inflateDirect() had to be exposed, I would have gone
down that path.

I read the code again just now and the shim class is rather odd and kludgey. 

For the sake of readability & clarity, I think I should move the entire method from the
shim into a package private method in ZlibDecompressor and get rid of the extra class overhead.

I will put this into PA tomorrow once the tests are done and they pass.

> Add a directbuffer Decompressor API to hadoop
> ---------------------------------------------
>
>                 Key: HADOOP-10047
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10047
>             Project: Hadoop Common
>          Issue Type: New Feature
>          Components: io
>            Reporter: Gopal V
>            Assignee: Gopal V
>              Labels: compression
>         Attachments: DirectCompressor.html, DirectDecompressor.html, HADOOP-10047-redo-WIP.patch,
HADOOP-10047-WIP.patch, HADOOP-10047-with-tests.patch
>
>
> With the Zero-Copy reads in HDFS (HDFS-5260), it becomes important to perform all I/O
operations without copying data into byte[] buffers or other buffers which wrap over them.
> This is a proposal for adding a DirectDecompressor interface to the io.compress, to indicate
codecs which want to surface the direct buffer layer upwards.
> The implementation should work with direct heap/mmap buffers and cannot assume .array()
availability.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message