hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi OZAWA (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-9822) create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
Date Tue, 06 Aug 2013 08:30:48 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-9822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tsuyoshi OZAWA updated HADOOP-9822:
-----------------------------------

    Summary: create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache
constructor  (was: create constant maxCapacity in RetryCache rather than hard-coding 16 in
RetryCache constructor)
    
> create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
> -----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-9822
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9822
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.3.0, 2.1.1-beta
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>            Priority: Minor
>         Attachments: HADOOP-9822.1.patch
>
>
> The magic number "16" is also used in ClientId.BYTE_LENGTH, so hard-coding magic number
"16" is a bit confusing.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message