hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9792) Retry the methods that are tagged @AtMostOnce along with @Idempotent
Date Tue, 30 Jul 2013 05:09:48 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9792?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13723408#comment-13723408

Jing Zhao commented on HADOOP-9792:

The patch looks pretty good to me. Only one minor in RetryInvocationHandler.java:
+        if (!isMethodIdempotent) {
+          isMethodIdempotent = proxyProvider.getInterface()
+              .getMethod(method.getName(), method.getParameterTypes())
+              .isAnnotationPresent(AtMostOnce.class);
+        }

Here we also need to rename "isMethodIdempotent" to isIdempotentOrAtMostOnce? +1 pending Jenkins
with the change.
> Retry the methods that are tagged @AtMostOnce along with @Idempotent
> --------------------------------------------------------------------
>                 Key: HADOOP-9792
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9792
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: ipc
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HADOOP-9792.patch
> Currently the operations marked as @Idempotent are retried. Now that we have added new
operations that are marked @AtMostOnce that guaranteed to be executed only once with the help
of RetryCache on server implementation, these methods should also be retried.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message