hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-8982) TestSocketIOWithTimeout fails on Windows
Date Wed, 22 May 2013 19:02:20 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8982?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Nauroth updated HADOOP-8982:
----------------------------------

    Attachment: HADOOP-8982.1.patch

After many, many failed attempts to simulate partial writes on Windows, I'm submitting a patch
that bypasses just the portion of the test that depends on partial write when running on Windows.

The earlier analysis is correct that the test is not able to observe partial write on Windows.
 At first, I thought the behavior was strictly due to differences in implementation of pipes
between Linux and Windows, so I tried changing the test to use a real network socket.  Then,
I tried ever-increasing write buffer sizes.  None of my attempts successfully simulated partial
write on Windows.  At this point, I think we need to skip this portion of the test on Windows.

This page lists some interesting differences between Unix and Windows sockets:

http://itamarst.org/writings/win32sockets.html

The last point is particularly relevant.
                
> TestSocketIOWithTimeout fails on Windows
> ----------------------------------------
>
>                 Key: HADOOP-8982
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8982
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: net
>    Affects Versions: 3.0.0
>            Reporter: Chris Nauroth
>            Assignee: Chris Nauroth
>         Attachments: HADOOP-8982.1.patch
>
>
> This is a possible race condition or difference in socket handling on Windows.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message