hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-9489) Eclipse instructions in BUILDING.txt don't work
Date Sun, 21 Apr 2013 06:09:18 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-9489?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Nauroth updated HADOOP-9489:
----------------------------------

    Attachment: HADOOP-9489.1.patch

Hi, [~cwsteinbach].  I think I understand what's going wrong with fresh imports of the project,
and I'm attaching a patch that attempts to fix it.  Would you mind trying out this patch in
your environment to see if it works for you?

Here is a summary of what I did:

# I changed BUILDING.txt to state that m2eclipse is required, that you should do an mvn install
of the whole Hadoop project (not just hadoop-maven-plugins), and that you should import by
clicking File -> Import -> Maven -> Existing Maven Projects.  Once I did it this
way, a fresh import showed ~100 errors.
# hadoop-common still had some errors for missing compiled protoc test sources.  This was
because the pom.xml was not specifying generated-test-sources/java as a source directory.
 I added a call to build-helper-maven-plugin to set that up correctly.  This eliminated ~40
errors for me.
# m2eclipse didn't know how to handle the goals in our custom Maven plugin for calling protoc
and generating version info.  I updated the top-level pom.xml to run the protoc goal during
an Eclipse build and ignore the version-info goal.  This eliminated nearly all of the remaining
~60 errors.

After all of that, a fresh import still gives me one error:

{quote}
Project 'hadoop-streaming' is missing required source folder: '/Users/chris/git/hadoop-common/hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/conf'
{quote}

It appears that Eclipse doesn't like us to have a test resource pointing at a path outside
of the module.  I'm not yet sure how to fix this one (other than just copying the file we
need out of hadoop-yarn-server-resourcemanager into hadoop-streaming, but then we'd have a
double-maintenance issue).  It doesn't appear to be fatal though.

I'm curious to see if these fixes address all of the problems that you saw.  Thanks!
                
> Eclipse instructions in BUILDING.txt don't work
> -----------------------------------------------
>
>                 Key: HADOOP-9489
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9489
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>            Reporter: Carl Steinbach
>            Assignee: Chris Nauroth
>         Attachments: eclipse_hadoop_errors.txt, HADOOP-9489.1.patch
>
>
> I have tried several times to import Hadoop trunk into Eclipse following the instructions
in the BUILDING.txt file, but so far have not been able to get it to work.
> If I use a fresh install of Eclipse 4.2.2, Eclipse will complain about an undefined M2_REPO
environment variable. I discovered that this is defined automatically by the M2Eclipse plugin,
and think that the BUILDING.txt doc should be updated to explain this.
> After installing M2Eclipse I tried importing the code again, and now get over 2500 errors
related to missing class dependencies. Many of these errors correspond to missing classes
in the oah*.proto namespace, which makes me think that 'mvn eclipse:eclipse' is not triggering
protoc. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message