hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Binglin Chang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8990) Some minor issus in protobuf based ipc
Date Tue, 22 Jan 2013 05:06:13 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8990?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13559402#comment-13559402

Binglin Chang commented on HADOOP-8990:

Sorry, I made a mistake, looks like currently RPC response doesn't have 4 byte total length,
and you plan to add 4 byte total length to rpc response right? If that's the case, I think
you are right, it is fine for non-blocking IO, although the prefix in rpc response body seams
And since the total length is not known until response header and response body are serialized
to some pre-allocated buffer to get the serialized size, so you plan to serialize header and
body to some buffer first and then write to socket, IMO this is the same as using a single
protobuf to include both header and body, 

> Some minor issus in protobuf based ipc
> --------------------------------------
>                 Key: HADOOP-8990
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8990
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Binglin Chang
>            Priority: Minor
> 1. proto file naming
> RpcPayloadHeader.proto include not only RpcPayLoadHeaderProto, but also RpcResponseHeaderProto,
which is irrelevant to the file name.
> hadoop_rpc.proto only include HadoopRpcRequestProto, and the filename "hadoop_rpc" is
strange comparing to other .proto file names.
> How about merge those two file into HadoopRpc.proto?
> 2. proto class naming
> In rpc request RpcPayloadHeaderProto includes callId, but in rpc response callId is included
in RpcResponseHeaderProto, and there is also HadoopRpcRequestProto, this is just too confusing.
> 3. The rpc system is not fully protobuf based, there are still some Writables:
> RpcRequestWritable and RpcResponseWritable.
> rpc response exception name and stack trace string.
> And RpcRequestWritable uses protobuf style varint32 prefix, but RpcResponseWritable uses
int32 prefix, why this inconsistency?
> Currently rpc request is splitted into length, PayLoadHeader and PayLoad, and response
into RpcResponseHeader, response and error message. 
> I think wrap request and response into single RequstProto and ResponseProto is better,
cause this gives a formal complete wire format definition, 
> or developer need to look into the source code and hard coding the communication format.
> These issues above make it very confusing and hard for developers to use these rpc interfaces.
> Some of these issues can be solved without breaking compatibility, but some can not,
but at least we need to know what will be changed and what will stay stable?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message