hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7868) Hadoop native fails to compile when default linker option is -Wl,--as-needed
Date Wed, 28 Nov 2012 12:45:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13505422#comment-13505422
] 

Hudson commented on HADOOP-7868:
--------------------------------

Integrated in Hadoop-Hdfs-0.23-Build #449 (See [https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/449/])
    HADOOP-7868. Hadoop native fails to compile when default linker option is -Wl,--as-needed.
(Trevor Robinson via tgraves) (Revision 1414370)

     Result = SUCCESS
tgraves : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1414370
Files : 
* /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/CHANGES.txt
* /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/acinclude.m4
* /hadoop/common/branches/branch-0.23/hadoop-common-project/hadoop-common/src/main/native/configure.ac

                
> Hadoop native fails to compile when default linker option is -Wl,--as-needed
> ----------------------------------------------------------------------------
>
>                 Key: HADOOP-7868
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7868
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: native
>    Affects Versions: 1.0.0, 2.0.0-alpha
>         Environment: Ubuntu Precise, Ubuntu Oneiric, Debian Unstable
>            Reporter: James Page
>            Assignee: Trevor Robinson
>             Fix For: 1.2.0, 2.0.2-alpha, 0.23.6
>
>         Attachments: hadoop-7868-b1.txt, HADOOP-7868.patch, HADOOP-7868-portable.patch
>
>
> Recent releases of Ubuntu and Debian have switched to using --as-needed as default when
linking binaries.
> As a result the AC_COMPUTE_NEEDED_DSO fails to find the required DSO names during execution
of configure resulting in a build failure.
> Explicitly using "-Wl,--no-as-needed" in this macro when required resolves this issue.
> See http://wiki.debian.org/ToolChain/DSOLinking for a few more details

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message