hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8985) Add namespace declarations in .proto files for languages other than java
Date Sat, 27 Oct 2012 17:15:12 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8985?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13485474#comment-13485474
] 

Hadoop QA commented on HADOOP-8985:
-----------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12551082/HADOOP-8985-add-namespace.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 2 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-common-project/hadoop-common.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1680//testReport/
Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1680//console

This message is automatically generated.
                
> Add namespace declarations in .proto files for languages other than java
> ------------------------------------------------------------------------
>
>                 Key: HADOOP-8985
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8985
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Binglin Chang
>            Assignee: Binglin Chang
>            Priority: Minor
>         Attachments: HADOOP-8985-add-namespace.patch
>
>
> Currently .proto files use java_package to specify java packages in proto files, but
namespace are not specified for other languages such as cpp, this causes name collision in
cpp. we can add namespace declarations to avoid this. 
> In Java, the package specifier is used as the Java package, unless you explicitly provide
a option java_package in your .proto file. So the original java package will not be affected.
> About namespace name, how about "hadoop.common"(hadoop::common in cpp) for all common
sub-project proto files, and "hadoop.hdfs"(hadoop::hdfs in cpp) for all hdfs sub-project proto
files?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message