hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun C Murthy (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (HADOOP-8700) Move the checksum type constants to an enum
Date Thu, 11 Oct 2012 17:45:41 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8700?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arun C Murthy closed HADOOP-8700.
---------------------------------

    
> Move the checksum type constants to an enum
> -------------------------------------------
>
>                 Key: HADOOP-8700
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8700
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>             Fix For: 0.23.3, 2.0.2-alpha
>
>         Attachments: c8700_20120815b.patch, c8700_20120815.patch, hadoop-8700-branch-0.23.patch.txt
>
>
> In DataChecksum, there are constants for crc types, crc names and crc sizes.  We should
move them to an enum for better coding style.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message