hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8901) GZip and Snappy support may not work without unversioned libraries
Date Tue, 09 Oct 2012 00:42:03 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8901?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13472000#comment-13472000

Colin Patrick McCabe commented on HADOOP-8901:

I also tested this with snappy.
> GZip and Snappy support may not work without unversioned libraries
> ------------------------------------------------------------------
>                 Key: HADOOP-8901
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8901
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: native
>    Affects Versions: 2.0.3-alpha
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>            Priority: Minor
>         Attachments: HADOOP-8901.001.patch
> Currently, we use {{dlopen}} to open {{libz.so}} and {{libsnappy.so}}, to get Gzip and
Snappy support, respectively.
> However, this is not correct; we should be dlopening {{libsnappy.so.1}} instead.  The
versionless form of the shared library is not commonly installed except by development packages.
 Also, we may run into subtle compatibility problems if a new version of libsnappy comes out.
> For libz, I believe we should simply link normally against it, rather than loading it
using {{dlopen}}.  It is part of the base Linux install for every distribution I'm aware of,
so let's not overcomplicate things.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message