hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-8895) TokenRenewer should be an interface, it is currently a fully abstract class
Date Mon, 08 Oct 2012 23:28:03 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8895?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Karthik Kambatla updated HADOOP-8895:

    Attachment: HADOOP-8895.patch


Thanks for your input. 

Though it is not absolutely necessary for {{TokenRenewer}} to be an interface, I felt it would
make things simpler when working on HDFS-4009.

For instance, if a {{WebHdfsFileSystem}} could implement {{TokenRenewer}}, we might not need
 {{DelegationTokenRenewer.Renewable}}. Now that we are removing {{DelegationTokenRenewer}}
completely - {{HADOOP-8891}} - it won't be immediately applicable. However, I was not sure
why it should be an abstract class.

Do you think we should leave it as is? Is there an advantage of abstract class over interface?

I am uploading a patch with my proposed changes.
> TokenRenewer should be an interface, it is currently a fully abstract class
> ---------------------------------------------------------------------------
>                 Key: HADOOP-8895
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8895
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.0.1-alpha
>            Reporter: Karthik Kambatla
>            Assignee: Karthik Kambatla
>            Priority: Minor
>         Attachments: HADOOP-8895.patch
> TokenRenewer is a fully abstract class. Making it an interface will allow classes extending
other classes to implement the interface.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message