hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8745) Incorrect version numbers in hadoop-core POM
Date Thu, 06 Sep 2012 06:56:08 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8745?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13449474#comment-13449474
] 

Eli Collins commented on HADOOP-8745:
-------------------------------------

How about just removing the kosmosfs section from the pom entirely? If we use 0.2.2 and it's
not available then that seems OK. kfs is an optional component anyway.
                
> Incorrect version numbers in hadoop-core POM
> --------------------------------------------
>
>                 Key: HADOOP-8745
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8745
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 1.0.3
>            Reporter: Matthias Friedrich
>            Priority: Minor
>         Attachments: HADOOP-8745-branch-1.0.patch
>
>
> The hadoop-core POM as published to Maven central has different dependency versions than
Hadoop actually has on its runtime classpath. This can lead to client code working in unit
tests but failing on the cluster and vice versa.
> The following version numbers are incorrect: jackson-mapper-asl, kfs, and jets3t. There's
also a duplicate dependency to commons-net.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message