hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bo Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8805) Move protocol buffer implementation of GetUserMappingProtocol from HDFS to Common
Date Mon, 17 Sep 2012 22:59:07 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8805?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13457448#comment-13457448

Bo Wang commented on HADOOP-8805:

Thanks for the comments, Alejandro.

Replies inline.

* GetUserMappingProtocol.proto:
** package name 'proto' seems to depart from the naming conventions being use, ti should be
Currently all protobuf generated packages use proto as the name. We can just follow the convention.
** class name should remain GetUserMappingsProtocolProtos following current naming conventions.
* Why the rename of GetUserMappingsProtocolClientSideTranslatorPB/GetUserMappingsProtocolServerSideTranslatorPB
classes? This seems to depart for the current naming convention?
I was following the YARN naming conventions. We'll keep HDFS naming convention which is along
the lines of the naming convention used in Common.
* GetUserMappingsProtocolPB: the InterfaceAudience seems it should be only HDFS & YARN,
not MapReduce, correct?

Will upload a new patch reflecting these feedbacks.

> Move protocol buffer implementation of GetUserMappingProtocol from HDFS to Common
> ---------------------------------------------------------------------------------
>                 Key: HADOOP-8805
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8805
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Bo Wang
>            Assignee: Bo Wang
>         Attachments: HADOOP-8805.patch, HADOOP-8805-v2.patch, HADOOP-8805-v3.patch
> org.apache.hadoop.tools.GetUserMappingProtocol is used in both HDFS and YARN. We should
move the protocol buffer implementation from HDFS to Common so that it can also be used by

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message