hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7891) KerberosName method typo and log warning when rules are set
Date Sat, 22 Sep 2012 15:05:08 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7891?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13461182#comment-13461182
] 

Hadoop QA commented on HADOOP-7891:
-----------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12546163/HADOOP-7891.patch
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 eclipse:eclipse.  The patch built with eclipse:eclipse.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit
warnings.

    +1 core tests.  The patch passed unit tests in hadoop-common-project/hadoop-auth hadoop-common-project/hadoop-common.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/1498//testReport/
Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/1498//console

This message is automatically generated.
                
> KerberosName method typo and log warning when rules are set
> -----------------------------------------------------------
>
>                 Key: HADOOP-7891
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7891
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: security
>    Affects Versions: 0.23.1
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>            Priority: Minor
>         Attachments: HADOOP-7891.patch
>
>
> The method hasRulesBeenSet() should be named haveRulesBeenSet()
> if the rules setting is not done during UGI initialization because they have been already
set, a warning should be logged. Along the following lines:
>   "Not setting kerberos name mappings defined in hadoop.security.auth_to_local because
name mappings are already set")

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message