hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-8700) Move the checksum type constants to an enum
Date Wed, 15 Aug 2012 10:12:38 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8700?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Tsz Wo (Nicholas), SZE updated HADOOP-8700:

    Status: Patch Available  (was: Open)
> Move the checksum type constants to an enum
> -------------------------------------------
>                 Key: HADOOP-8700
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8700
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>         Attachments: c8700_20120815.patch
> In DataChecksum, there are constants for crc types, crc names and crc sizes.  We should
move them to an enum for better coding style.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message