hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Friedrich (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8745) Incorrect version numbers in hadoop-core POM
Date Fri, 31 Aug 2012 08:30:08 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8745?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13445767#comment-13445767
] 

Matthias Friedrich commented on HADOOP-8745:
--------------------------------------------

Thanks for your review! I don't know kfs, but I think there's some confusion because Hadoop's
kfs-0.2.2 uses {{org.kosmix}} as the groupId while kfs-0.3 uses {{net.sf.kosmosfs}} as the
groupId. It's the same package though, in Java they both use the {{org.kosmix}} package name
space. It's commented in the ivy config because kfs-0.2.2 and older aren't available through
Maven central. This is why the lib is checked into svn.

The problem with my patch is that we can't downgrade to kfs-0.2.2 without causing problems
for Maven users. There are three options: 1) leave it at 0.3, 2) deploy kfs 0.2.2 to Maven
central, or 3) upgrade Hadoop to use kfs-0.3. Option 3 sounds like the best but I have no
way of testing this (there's no test case and wiki documentation seems to have moved on to
Hadoop 2). It compiles with some warnings, but whether it actually works is a different question.
                
> Incorrect version numbers in hadoop-core POM
> --------------------------------------------
>
>                 Key: HADOOP-8745
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8745
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 1.0.3
>            Reporter: Matthias Friedrich
>            Priority: Minor
>         Attachments: HADOOP-8745-branch-1.0.patch
>
>
> The hadoop-core POM as published to Maven central has different dependency versions than
Hadoop actually has on its runtime classpath. This can lead to client code working in unit
tests but failing on the cluster and vice versa.
> The following version numbers are incorrect: jackson-mapper-asl, kfs, and jets3t. There's
also a duplicate dependency to commons-net.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message