hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-8700) Move the checksum type constants to an enum
Date Tue, 21 Aug 2012 03:06:38 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8700?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tsz Wo (Nicholas), SZE updated HADOOP-8700:
-------------------------------------------


Merged to branch-0.23.
                
> Move the checksum type constants to an enum
> -------------------------------------------
>
>                 Key: HADOOP-8700
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8700
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>             Fix For: 0.23.3, 2.2.0-alpha
>
>         Attachments: c8700_20120815b.patch, c8700_20120815.patch, hadoop-8700-branch-0.23.patch.txt
>
>
> In DataChecksum, there are constants for crc types, crc names and crc sizes.  We should
move them to an enum for better coding style.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message