hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8736) Create a Builder to make an RPC server
Date Tue, 28 Aug 2012 11:13:07 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13443069#comment-13443069

Suresh Srinivas commented on HADOOP-8736:

Thanks Brandon for doing this. This cleanup improves the readability of the code.

I have not reviewed the patch completely. Here are my early comments:
# Can you add javadoc to the newly added class {{Builder}}
# Instead of deprecating getServer() methods, why not get rid of those methods altogether?
You could also leave those methods for now and get rid of them in another jira.
# Typo: method name "setProt" should be "setProto"
# Some of the values while building protocol engine, such as protocol, instance, etc. cannot
have default values. It would be good to either add check for that in Builder or ensure it
is is checked in {{getProtocolEngine()}} implementation.

> Create a Builder to make an RPC server
> --------------------------------------
>                 Key: HADOOP-8736
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8736
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: ipc
>    Affects Versions: 3.0.0
>            Reporter: Brandon Li
>            Assignee: Brandon Li
>         Attachments: HADOOP-8736.patch, HADOOP-8736.patch
> There are quite a few variants of getServer() method to create an RPC server. Create
a builder class to abstract the building steps and avoid more getServer() variants in the

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message