hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Willis (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-8623) hadoop jar command should respect HADOOP_OPTS
Date Wed, 25 Jul 2012 22:43:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8623?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steven Willis updated HADOOP-8623:
----------------------------------

    Attachment: HADOOP-8623.patch

Since every case in the big if block have would now had:
{code}HADOOP_OPTS="$HADOOP_OPTS $HADOOP_CLIENT_OPTS"{code}

I just removed each individual line and added a single line below the block. It has the nice
side affect of making that big block more readable
                
> hadoop jar command should respect HADOOP_OPTS
> ---------------------------------------------
>
>                 Key: HADOOP-8623
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8623
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 0.23.1, 2.0.0-alpha
>            Reporter: Steven Willis
>         Attachments: HADOOP-8623.patch
>
>
> The jar command to the hadoop script should use any set HADOOP_OPTS and HADOOP_CLIENT_OPTS
environment variables like all the other commands.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message