hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Graves (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-7470) move up to Jackson 1.8.8
Date Tue, 26 Jun 2012 18:29:44 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-7470?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Thomas Graves updated HADOOP-7470:
----------------------------------

    Hadoop Flags: Incompatible change,Reviewed  (was: Reviewed)

Marking this as incompatible since any applications that had dependency on old jackson version
now break and would required change to upgrade. 

If there is preferred way to indicate that please let me know.
                
> move up to Jackson 1.8.8
> ------------------------
>
>                 Key: HADOOP-7470
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7470
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>    Affects Versions: 0.20.203.0
>            Reporter: Steve Loughran
>            Assignee: Enis Soztutar
>            Priority: Minor
>             Fix For: 1.0.1, 0.23.1, 0.24.0
>
>         Attachments: hadoop-1.0-jackson_v1.patch, hadoop-trunk-jackson_v1.patch
>
>   Original Estimate: 0.25h
>  Remaining Estimate: 0.25h
>
> I see that hadoop-core still depends on Jackson 1.0.1 -but that project is now up to
1.8.2 in releases. Upgrading will make it easier for other Jackson-using apps that are more
up to date to keep their classpath consistent.
> The patch would be updating the ivy file to pull in the later version; no test

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message