hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Foley (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Edited] (HADOOP-7211) Security uses proprietary Sun APIs
Date Sun, 06 May 2012 21:48:48 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7211?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13248095#comment-13248095
] 

Matt Foley edited comment on HADOOP-7211 at 5/6/12 9:48 PM:
------------------------------------------------------------

On HADOOP-6941, my aim was to make the hadoop code base compile with IBM's JDK, and ensure
that there is no regression with Oracle's. I had done testing of HDFS/MR with security enabled.
I didn't do the tests that would go through the SecurityUtil code path though (argh) - fixed
in HADOOP-8251. 
                
      was (Author: devaraj):
    On HADOOP-6941, my aim was to make the hadoop code base compile with IBM's JDK, and ensure
that there is no regression with Oracle's. I had done testing of HDFS/MR with security enabled.
I didn't do the tests that would go through the SecurityUtil code path though (argh) [fixed
in HADOOP-8251]. 
                  
> Security uses proprietary Sun APIs
> ----------------------------------
>
>                 Key: HADOOP-7211
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7211
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: security
>            Reporter: Eli Collins
>            Assignee: Luke Lu
>
> The security code uses the KrbException, Credentials, and PrincipalName classes from
sun.security.krb5 and Krb5Util from sun.security.jgss.krb5. These may disappear in future
Java releases. Also Hadoop does not compile using jdks that do not support them, for example
with the following IBM JDK.
> {noformat}
> $ /home/eli/toolchain/java-x86_64-60/bin/java -version
> java version "1.6.0"
> Java(TM) SE Runtime Environment (build pxa6460sr9fp1-20110208_03(SR9 FP1))
> IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux amd64-64 jvmxa6460sr9-20110203_74623
(JIT enabled, AOT enabled)
> J9VM - 20110203_074623
> JIT  - r9_20101028_17488ifx3
> GC   - 20101027_AA)
> JCL  - 20110203_01
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message