hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Graves (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8451) slightly inconsistent file names for native code
Date Wed, 30 May 2012 18:22:23 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13285868#comment-13285868
] 

Thomas Graves commented on HADOOP-8451:
---------------------------------------

note that anything under ./hadoop-mapreduce-project/src/ is old mrv1 and if it is to be continued
to be used should be mavenized and moved under other directories.  MAPREDUCE-4267 will handle
pipes and utils listed here.
                
> slightly inconsistent file names for native code
> ------------------------------------------------
>
>                 Key: HADOOP-8451
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8451
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Colin Patrick McCabe
>            Priority: Trivial
>
> During HADOOP-8368, someone pointed out that it would be nice for the C/C++ files to
be in directories named 'native'.  However, this is currently not the case.
> Some examples:
> [from hadoop-common]
> {code}
> ./test/system/c++/runAs/main.c
> ./test/system/c++/runAs/runAs.c
> ./main/native/src/org/apache/hadoop/util/NativeCrc32.c
> ./main/native/src/org/apache/hadoop/util/bulk_crc32.c
> ...etc..
> {code}
> From hadoop-hdfs:
> {code}
> ./hadoop-hdfs/src/contrib/fuse-dfs/src/fuse_impls_readdir.c
> ./hadoop-hdfs/src/contrib/fuse-dfs/src/fuse_impls_utimens.c
> ./hadoop-hdfs/src/main/native/hdfs_read.c
> ./hadoop-hdfs/src/main/native/hdfs.c
> ... etc...
> {code}
> From hadoop-mapreduce-project:
> {code}
> ./hadoop-mapreduce-project/src/examples/pipes/impl/wordcount-simple.cc
> ./hadoop-mapreduce-project/src/examples/pipes/impl/wordcount-part.cc
> ./hadoop-mapreduce-project/src/c++/utils/impl/StringUtils.cc
> ./hadoop-mapreduce-project/src/c++/utils/impl/SerialUtils.cc
> ./hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/native/container-executor/test/test-container-executor.c
> ./hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/native/container-executor/impl/main.c
> ... etc...
> {code}
> There's probably a little more we could do to tidy this up... at minimum, pick one of
'c++' or 'native' and use it consistently.  So this JIRA is a reminder.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message