hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Joseph Evans (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-8278) Make sure components declare correct set of dependencies
Date Wed, 18 Apr 2012 20:04:40 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8278?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Robert Joseph Evans updated HADOOP-8278:

    Target Version/s: 2.0.0, 3.0.0  (was: 2.0.0, 0.23.3)
> Make sure components declare correct set of dependencies
> --------------------------------------------------------
>                 Key: HADOOP-8278
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8278
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build
>            Reporter: Tom White
> As mentioned by Scott Carey in https://issues.apache.org/jira/browse/MAPREDUCE-3378?focusedCommentId=13173437&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13173437,
we need to make sure that components are declaring the correct set of dependencies. In current
trunk there are errors of omission and commission (as reported by 'mvn dependency:analyze'):
> * "Used undeclared dependencies" - these are dependencies that are being met transitively.
They should be added explicitly as "compile" or "provided" scope.
> * "Unused declared dependencies" - these are dependencies that are not needed for compilation,
although they may be needed at runtime. They certainly should not be "compile" scope - they
should either be removed or marked as "runtime" or "test" scope.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message