hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Lewis (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-8067) Errors building hadoop-gpl-compression with Hadoop 1.0.0 and HBase 0.92.0
Date Mon, 13 Feb 2012 22:18:59 GMT
Errors building hadoop-gpl-compression with Hadoop 1.0.0 and HBase 0.92.0
-------------------------------------------------------------------------

                 Key: HADOOP-8067
                 URL: https://issues.apache.org/jira/browse/HADOOP-8067
             Project: Hadoop Common
          Issue Type: Bug
          Components: build
    Affects Versions: 1.0.0
         Environment: Red Hat 5.5 64bit

            Reporter: John Lewis


We were able to successfully configure and run HBase 0.92.0 on top of Hadoop 1.0.0. But when
we were following the directions stated on http://wiki.apache.org/hadoop/UsingLzoCompression
on enabling LZO compression in HBase we are getting errors building hadoop-gpl-compression
with the hadoop-core-1.0.0.jar. These errors seem to be a result of different classes being
deprecated. 

When we use an older version of hadoop core jar such as hadoop-core-0.20.2.jar, we are able
to build the hadoop-gpl-compression-0.1.0-dev.jar and native folder with no errors. Also after
copying those files to the HBase library LZO functions without any errors even with HBase
being on top of Hadoop 1.0.0.

Is there an LZO build compatible with Hadoop 1.0.0?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message