hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Pollack (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7944) Would like to update development getting started pages on hadoop wiki but don't have permission
Date Fri, 30 Dec 2011 17:42:30 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7944?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13177708#comment-13177708
] 

Mark Pollack commented on HADOOP-7944:
--------------------------------------

In the footnotes, add a line to give context, e.g.  If you try to import a pom.xml (existing
maven project) into eclipse you may encounter some problems.  <existing text>

I don't think 'ant' is required anymore in the 0.23 build is it?  If so it could be removed
as a required packaged to install.  Seems like there needs to be a separation between pre
0.23 and >= 0.23 documentation for getting started.  Ping me when the larger wiki effort
kicks off.  I might update the IntelliJ docs as well in the meantime.




                
> Would like to update development getting started pages on hadoop wiki but don't have
permission
> -----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-7944
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7944
>             Project: Hadoop Common
>          Issue Type: Task
>          Components: documentation
>    Affects Versions: 0.23.0
>         Environment: Ubuntu 10.04.2 LTS
>            Reporter: Mark Pollack
>            Priority: Minor
>
> I've created an account on the wiki but can't edit pages.
> The wiki page http://wiki.apache.org/hadoop/EclipseEnvironment has some out of date information,
for example 
> mvn test -DskipTests
> mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
> cd ../; cd mapreduce; ant compile eclipse
> should be
> mvn install -DskipTests
> mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
> 'install' is needed instead of test in order to get the build artifacts in the local
M2 repo for reference in the eclipse build path.  Also there isn't a 'mapreduce' directory
anymore and the mvn eclipse:eclipse command craetes the necessary .project files under the
0.23 'hadoop-mapreduce-project' directory.
> I'd also like to add a blurb about using eclipse with m2e/m2eclipse.  For a maven based
project many devs would just import the root pom.xmls.  With the new release of the m2e plug-in,
this doesn't work anymore as pretty much all targets are not supported by the new 'connector
framework' - yes, it is a giant mess.  This means falling back to m2eclipse or just doing
the eclipse generation as mention.
> Adding a pointer to http://wiki.apache.org/hadoop/HowToContribute such that the requirements
to install java, maven, and protoc compilers would be helpful.  The information on getting
started from scratch seems a bit scattered and I'd like to help clean that up.
> Please let me know how I can help to contribute in this area.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message