hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7776) Make the Ipc-Header in a RPC-Payload an explicit header
Date Tue, 01 Nov 2011 17:53:33 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7776?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13141385#comment-13141385

Suresh Srinivas commented on HADOOP-7776:

# Client.java
#* Comment describing members of Call can be alinged
#* Use rpcResponse instead of rpcResult
#* Make Call#rpcKind, Call#param and Call#id final
#* ParallelCall is alway of kind Writable? Should we get rid of ParallelCall in a separate
#* With rpcKind added to method some of the javadoc @link without rpcKind generate warnings.
# RpcPayloadHeader
#* RpcPayloadHeader javadoc could explaing the wire format better.
#* Indentation of readFields is missing a space
#* Is RpcPayloadType a better name for RpcPayloadOperation
#* Need better description of RpcPayloadOperation enums
# Server.java
#* Call - a lot of member vars could be final including rpcKind
#* rpcKind is not used in the server.

> Make the Ipc-Header in a RPC-Payload an explicit header
> -------------------------------------------------------
>                 Key: HADOOP-7776
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7776
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Sanjay Radia
>            Assignee: Sanjay Radia
>         Attachments: RpcPayLoadHeader.java, rpcPayload1.patch, rpcPayload2.patch, rpcPayload3.patch

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message