hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Radim Kolar (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7382) hadoop 0.20.203.0 Eclipse Plugin does not work with Eclipse
Date Sun, 02 Oct 2011 17:44:34 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7382?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13119042#comment-13119042
] 

Radim Kolar commented on HADOOP-7382:
-------------------------------------

In Eclipse plugin i got following error while trying to add Map/Reduce location

An internal error occurred during: "Map/Reduce location status updater".
org/codehaus/jackson/map/JsonMappingException

and in eclipse log

!ENTRY org.eclipse.core.jobs 4 2 2011-10-02 19:06:17.154
!MESSAGE An internal error occurred during: "Map/Reduce location status updater".
!STACK 0
java.lang.NoClassDefFoundError: org/codehaus/jackson/map/JsonMappingException
	at org.apache.hadoop.eclipse.server.HadoopServer.getJobClient(HadoopServer.java:473)
	at org.apache.hadoop.eclipse.server.HadoopServer$LocationStatusUpdater.run(HadoopServer.java:102)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: java.lang.ClassNotFoundException: org.codehaus.jackson.map.JsonMappingException
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:513)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	... 3 more

                
> hadoop 0.20.203.0 Eclipse Plugin does not work with Eclipse
> -----------------------------------------------------------
>
>                 Key: HADOOP-7382
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7382
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: contrib/eclipse-plugin
>    Affects Versions: 0.20.203.0
>         Environment: window 7 ; eclipse3.6-rc2
>            Reporter: shanlin
>            Priority: Blocker
>              Labels: hadoop
>
> hadoop 0.20.203.0 Eclipse Plugin does not work with Eclipse,while adding DFS Locations,Advance
parameters didin't hava a option hadoop.job.ugi

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message