hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Foley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7435) Make pre-commit checks run against the correct branch
Date Thu, 15 Sep 2011 20:39:09 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13105667#comment-13105667

Matt Foley commented on HADOOP-7435:

A naming convention has now been established in the wiki page [HowToContribute|http://wiki.apache.org/hadoop/HowToContribute].
 It says:

bq. Patches for trunk should be named jira-xyz.patch, eg hdfs-123.patch. Patches for a specific
branch should be named jira-xyz-branch.patch, eg hdfs-123-branch-0.20-security. ... The branch
name allows the pre-commit tests to run against the correct branch.

Okay, so we need to tweak the patch-testing robot to examine the trailing set of hyphen-separated
components of the patch name to see if it matches any Hadoop branch names.  Not a perfect
spec, but sounds usable.

> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>             Fix For: 0.23.0
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk.
It'd be nice if this could be extended to automatically run against the correct branch.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message