hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shani Afrimi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-7544) part of the data is transferred over eth0 even after configuring eth1 in mapred-site.xml and hdfs-site.xml
Date Mon, 15 Aug 2011 11:23:27 GMT
part of the data is transferred over eth0 even after configuring eth1 in mapred-site.xml and
hdfs-site.xml
----------------------------------------------------------------------------------------------------------

                 Key: HADOOP-7544
                 URL: https://issues.apache.org/jira/browse/HADOOP-7544
             Project: Hadoop Common
          Issue Type: Bug
    Affects Versions: 0.20.203.0, 0.20.2
            Reporter: Shani Afrimi


I configure dfs.datanode.dns.interface & mapred.tasktracker.dns.interface to use eth1.
I then run terasort and used dstat to monitor the traffic on each of my interfaces.
Aparently, about 50% of the data is still being transferred over eth0.

The problem is only "solved" in case I manually change the hostnames and add appropriate entries
in /etc/hosts so resolving host's name - in my cluster - reaches eth1.  However, changing
the hostname is inappropriate for my production environment.

NOTE: This issue might be rlated to https://issues.apache.org/jira/browse/HADOOP-6797 .  However,
we know that our network is propely configured, and still it doesn't guarantee that reverseDns
will succeed.  Hence, we suffer a lot from this problem.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message